Bienvenido! - Willkommen! - Welcome!

Bitácora Técnica de Tux&Cía., Santa Cruz de la Sierra, BO
Bitácora Central: Tux&Cía.
Bitácora de Información Avanzada: Tux&Cía.-Información
May the source be with you!

Friday, December 20, 2013

TP-Link WN620G
Atheros 5523a-100
usb 2.0  "windows 7" wireless network adapter ar5523 driver
In case you have SMCWUSBT-G, this post may help in making it work with Windows 7.
I had major problems getting this work with Windows 7 (the manufacturer is not helpful despite requests for windows 7 drivers). But you can get it work with the drivers meant for previous windows versions.
1. Download the software/driver (SMCWUSBT-G_V1.11.000.ZIP) from 
2. Unzip & Install the software. We are only interested in two files from this installation.
Of course it may never work - You may be prompted to insert the adpater, but it may not recognise it & entire installation may even get cancelled. If you have problems, try the vista or xp compatibility option (Right click -> Properties -> Compatibility). 
As a last resort, if you have an XP machine/partition, install there (you can make use of the working SMCWUSBT-G installation if you have one on that machine/partition). 
3. Copy the two files ar5523.sys & ar5523.bin (from C:\Program Files\SMCWUSBT-G*) to a temp. directory, let us say, C:\Temp
4. Go to Device Manager & update the driver for AR5523 letting windows search for the drivers in C:\Temp (overriding any warnings). Windows 7 will install the drivers & it may be able to connect to the wireless networks. If not see 5.
You may uninstall the software installed in 2, if you managed to do so. It is not required.
5. I had varying success with the windows 7 bits - Beta/RC/RTM. While the above steps worked on Beta/RC bits, it did not work on the RTM bits. It turned out that I had to make a change on my SMCWBR14T-G router as well for the RTM bits to work - I had Super G-Static Turbo mode (proprietory I guess) enabled on the wireless router earlier - turned this off & enabled 802.11g. It started working & hopefully stays that way! (713.8 KB)
problem with TL-WN620G card and Windows 7 releases 7000, 7100 & 7127. The drivers would install fine, however, Win 7 was unable to connect to the internet without me setting up my wireless connection.
After a reboot Win 7 would not connect unless I either reconnected the card or set the network connection up again. I have now resolved the issue by using the Atheros AR5005-UG drivers.
Version1:  Atheros ZD1211B USB 
Prueba con este de la marca canyon, pero lleva chipset zd1211 y vale para windows 7 32bits y 64bits:
chipset zydas ZD1211B , aka Atheros AR5007UG (dale a download y espera 10s) (hay que forzar la instalacion del driver, desde administrador de dispositivos)

No comments: